Returnflows

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
We're experiencing issues
Resolved·Full outage

We’re back to normal performance, and all queued jobs have been successfully processed. We’ll continue to monitor closely over the next few hours.

Thu, Mar 19, 2026, 11:57 AM
(3 months ago)
·
Affected components
Mar 19, 2026, 11:10 AM
11:57 AM
Flows
Admin App
Updates

Resolved

We’re back to normal performance, and all queued jobs have been successfully processed. We’ll continue to monitor closely over the next few hours.

Thu, Mar 19, 2026, 11:57 AM

Identified

We’re seeing performance improvements and have moved all flows out of maintenance mode. Customers can now create returns again.

Thu, Mar 19, 2026, 11:31 AM(26 minutes earlier)

Investigating

We are currently experiencing an issue where users cannot access flows or the Returnflows Admin App. We are working hard on identifying the root cause and will provide updates as soon as possible.

Thu, Mar 19, 2026, 11:10 AM(21 minutes earlier)