Telenor has confirmed the incorrect block on our domain has been removed. Customers on private Telenor Denmark subscriptions should now be able to access return portals, tracking pages, and returnflows.com without issues.
Our platform was fully operational throughout. The block happened at DNS level on Telenor's side, so no data was ever at risk and all merchant integrations, APIs, and email notifications worked as normal.
DNS changes can take a little while to propagate. If you still see a "Blocked by SikkerSurf" page, try reconnecting to the network or restarting the device, and please let us know so we can follow up with Telenor.
Monitoring
Telenor has confirmed the incorrect block on our domain has been removed. Customers on private Telenor Denmark subscriptions should now be able to access return portals, tracking pages, and returnflows.com without issues.
Our platform was fully operational throughout. The block happened at DNS level on Telenor's side, so no data was ever at risk and all merchant integrations, APIs, and email notifications worked as normal.
DNS changes can take a little while to propagate. If you still see a "Blocked by SikkerSurf" page, try reconnecting to the network or restarting the device, and please let us know so we can follow up with Telenor.
Investigating
End customers on private Telenor Denmark subscriptions (home internet and mobile) may be unable to access return portals, tracking pages, and returnflows.com. Affected users see a browser security warning or a "Blocked by SikkerSurf" page. Business connections and all other internet providers are unaffected.
Our platform is fully operational. The issue is caused by "SikkerSurf", a content filter enabled on Telenor's private subscriptions, which is incorrectly blocking our domain at DNS level. Affected requests never reach our infrastructure; no data is at risk, and all merchant integrations, APIs, and email notifications are functioning normally.
We have contacted Telenor's security team with a request to remove the incorrect block and are actively following up.
Workaround for affected customers:
Open the link on a different network (e.g. another Wi-Fi, or a non-Telenor phone's hotspot),
Or the subscription owner can disable SikkerSurf under "Mit Telenor".