Shipmondo reports that Customs Handling when shipping via PostNord should we working as normal again. Incident is hereby marked as resolved.
Resolved
Shipmondo reports that Customs Handling when shipping via PostNord should we working as normal again. Incident is hereby marked as resolved.
Investigating
Shipmondo has reported issues with Customs Handling when shipping via PostNord. We are monitoring the situation closely